ПАНЕЛЬ УПРАВЛЕНИЯ
Логин :  
Пароль :  
 
Регистрация | Напомнить пароль?
Новости  |  Продукты  |  Релизы  |  Форум  |  Обратная связь
 
Навигация
Навигация
Главная
Продукты
Релизы
Решения
Форум
Модули
Шаблоны
Piracy Reports
Обратная связь
DLE Forum
Возможности
Скриншоты
Лицензионное соглашение
Календарь
«    Сентябрь 2012    »
ПнВтСрЧтПтСбВс
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Опрос
Оцените DLE Forum v.2.6.1

Отличный
Нормальный форум
Устраивает ... но ...
Встречал и получше
Совсем не понравился
Архив новостей
Январь 2012 (1)
Август 2011 (1)
Май 2011 (2)
Апрель 2011 (3)
Февраль 2011 (1)
Январь 2011 (4)
Теги
DLE Forum, DLE Forum 2.6.1, DLE Forum v.2.6, DLE Store, Форум для DataLife Engine
Реклама
Форум для DLE.
 
DLE-FILES.RU


5 страниц 1 2 3 4 5 Далее
Ответить
 DLE 9.3 + DLE-Forum 2.6.1, Собираем баги и ошибки для такой сборки
aigusev
14 мая 2011 16:42
Сообщение #1


Очень Активный
  • 85

Репутация: 35
Группа: Посетители
Сообщений: 377
Регистрация: 18.12.2009
ICQ:424534354
Пишем в данный топик найденные ошибки:

1. В панели администрирования форума ошибка:
Warning: Call-time pass-by-reference has been deprecated in /home/путь к сайту/engine/forum/classes/dle_forum_function.php on line 100
Warning: Call-time pass-by-reference has been deprecated in /home/путь к сайту/engine/forum/classes/dle_forum_function.php on line 119
Warning: Call-time pass-by-reference has been deprecated in /home/путь к сайту/engine/forum/classes/dle_forum_function.php on line 162

2. На странице с форумом следующая ошибка:
Warning: Call-time pass-by-reference has been deprecated in /home/путь к сайту/engine/forum/main.php on line 93
Warning: Call-time pass-by-reference has been deprecated in /home/путь к сайту/engine/forum/classes/dle_forum_function.php on line 100
Warning: Call-time pass-by-reference has been deprecated in /home/путь к сайту/engine/forum/classes/dle_forum_function.php on line 119
Warning: Call-time pass-by-reference has been deprecated in /home/путь к сайту/engine/forum/classes/dle_forum_function.php on line 162


Решение в .htaccess добавить
php_flag allow_call_time_pass_reference on

Сообщение отредактировал aigusev - 14 мая 2011 21:23
Перейти в начало страницы
Pentaru
14 мая 2011 18:02
Сообщение #2


DLE Files Group
  • 85

Репутация: 36
Группа: Модераторы
Сообщений: 535
Регистрация: 27.06.2008
ICQ:--
aigusev,
Форум был поставлен на чистый дистрибутив?

просто я обновлял дле, потом вручную установил форум(всвязи с обновлением ДЛЕ), ошибок никаких нет

Сообщение отредактировал Pentaru - 14 мая 2011 18:03
--------------------
Поддержка по ICQ, e-mail и ЛС не оказывается
Перейти в начало страницы
aigusev
14 мая 2011 19:39
Сообщение #3


Очень Активный
  • 85

Репутация: 35
Группа: Посетители
Сообщений: 377
Регистрация: 18.12.2009
ICQ:424534354
чистый дле обновленный с 9.2 до 9.3, затем установлен форум тоже вручную.
Попробовал еще раз на чистый свеже установленный двиг, результат тотже
Если добавить в .htaccess
php_flag allow_call_time_pass_reference on

то проблема решается

Сообщение отредактировал aigusev - 14 мая 2011 21:13
Перейти в начало страницы
foxer
21 мая 2011 12:45
Сообщение #4


Активный участник
  • 51

Репутация: 5
Группа: Посетители
Сообщений: 128
Регистрация: 1.08.2010
ICQ:--
Цитата: Pentaru
просто я обновлял дле, потом вручную установил форум

сделал также, ошибок не обнаружено :fellow:
Перейти в начало страницы
mlevox
22 мая 2011 10:37
Сообщение #5


Новичок
  • 17

Репутация: 3
Группа: Посетители
Сообщений: 16
Регистрация: 18.02.2010
ICQ:--
Форум с DLE 9.3 работает вполне стабильно. Обнаружил только один баг - если написать сообщение из формы быстрого ответа, то, после добавления, оно не удаляется из формы ответа. Может кто знает, как починить?
Перейти в начало страницы
foxer
24 мая 2011 11:09
Сообщение #6


Активный участник
  • 51

Репутация: 5
Группа: Посетители
Сообщений: 128
Регистрация: 1.08.2010
ICQ:--
Цитата: mlevox
если написать сообщение из формы быстрого ответа, то, после добавления, оно не удаляется из формы ответа. Может кто знает, как починить?

присоединяюсь к вопросу :winked:
Перейти в начало страницы
vikdo
26 мая 2011 09:50
Сообщение #7


Участник
  • 34

Репутация: 1
Группа: Посетители
Сообщений: 40
Регистрация: 30.05.2009
ICQ:--
Это у всех так стало на ДЛЕ 9.3?
Перейти в начало страницы
foxer
31 мая 2011 09:24
Сообщение #8


Активный участник
  • 51

Репутация: 5
Группа: Посетители
Сообщений: 128
Регистрация: 1.08.2010
ICQ:--
Вставку видео с youtube никто не пофиксил?
Перейти в начало страницы
pun
1 июня 2011 01:19
Сообщение #9


Новичок
  • 17

Репутация: 0
Группа: Посетители
Сообщений: 9
Регистрация: 1.06.2011
ICQ:--
Цитата: aigusev
Если добавить в .htaccess
php_flag allow_call_time_pass_reference on
то проблема решается


Проблема аналогичная, но добавление в .htaccess сайта этой строки вообще приводит к интернал сервер эрор и сайт вообще не работает (((

Разобрался! Данная настройка включается в панели управления хостингом и проблема действительно решается. В .htaccess тогда ничего не нужно добавлять.

Сообщение отредактировал pun - 1 июня 2011 01:28
Перейти в начало страницы
Mek
2 июня 2011 15:47
Сообщение #10


Очень Активный
  • 85

Репутация: 27
Группа: Посетители
Сообщений: 338
Регистрация: 1.11.2008
ICQ:763600
Работает ли HTML в сообщениях на связки DLE 9.3 + DLE-Forum 2.6.1 ?
Перейти в начало страницы
Blood
3 июня 2011 00:05
Сообщение #11


Новичок
  • 17

Репутация: 0
Группа: Посетители
Сообщений: 1
Регистрация: 25.01.2011
ICQ:--
pun,
Подробнее пззз, что и как ты сделал ...
Перейти в начало страницы
pun
3 июня 2011 23:24
Сообщение #12


Новичок
  • 17

Репутация: 0
Группа: Посетители
Сообщений: 9
Регистрация: 1.06.2011
ICQ:--
Цитата: Blood
Подробнее пззз, что и как ты сделал ...


Зашёл в панель управления, которую предоставляет хостинг-провайдер и в разделе настройки сайта - настройки php поставил галочку возле allow_call_time_pass_reference
Перейти в начало страницы
papeion
5 июня 2011 06:02
Сообщение #13


Участник
  • 34

Репутация: 1
Группа: Посетители
Сообщений: 48
Регистрация: 7.01.2008
ICQ:--
Цитата: mlevox
баг - если написать сообщение из формы быстрого ответа, то, после добавления, оно не удаляется из формы ответа.

Цитата: foxer
Вставку видео с youtube

Подтверждаю. У меня тоже два этих бага.
1) не удаляется текст из формы быстр. ответа
2) и не вставляется видео с youtube

...а ещё приходится ловить выпадающее меню, т.к. после вызова норовит тут же скрыться...
...а ещё при быстром редактировании сообщения в редакторе не работает выбор цвета...

Цитата: foxer
ошибок не обнаружено

Вау! И даже этих? :no: ...foxer, может ты плохо смотрел? Ведь по любому видео не должно вставляться т.к. изменился тег.

Сообщение отредактировал papeion - 5 июня 2011 17:25
Перейти в начало страницы
foxer
5 июня 2011 19:00
Сообщение #14


Активный участник
  • 51

Репутация: 5
Группа: Посетители
Сообщений: 128
Регистрация: 1.08.2010
ICQ:--
Цитата: papeion
Вау! И даже этих? :no: ...foxer, может ты плохо смотрел? Ведь по любому видео не должно вставляться т.к. изменился тег.

При обновлении ошибок не было и на первый взгляд функционала тоже, а потом уже заметил и про быстрый ответ и про ютуб.
Бывает иногда отредактируешь сообщение и нажимаешь Принять исправления и оно зависает на несколько секунд 10-15 секунд, это было и до обновления.
Перейти в начало страницы
papeion
6 июня 2011 07:30
Сообщение #15


Участник
  • 34

Репутация: 1
Группа: Посетители
Сообщений: 48
Регистрация: 7.01.2008
ICQ:--
Меня больше волнует вопрос "Почему спецы молчат по поводу этих багов?". Я уже пытался сам найти в файлах где этот тег youtube, чтобы методом тыка может быть его заменить на новый тег. Но не нашёл.
А по поводу 2-го бага вообще не пойму где и что и из-за чего такая фигня.
Эх, надо всё-таки учиться.
Перейти в начало страницы
mlevox
6 июня 2011 11:44
Сообщение #16


Новичок
  • 17

Репутация: 3
Группа: Посетители
Сообщений: 16
Регистрация: 18.02.2010
ICQ:--
Решил проблему с тегом youtube
Открываем файл engine/forum/classes/parse.class.php
1) Находим строку (349)
$source = preg_replace( "#\[youtube=([^\]]+)\]#ies", "\$this->build_youtube('\\1')", $source );


Заменяем на
$source = preg_replace( "#\[media=([^\]]+)\]#ies", "\$this->build_youtube('\\1')", $source );


2) Находим строку (396)
$txt = preg_replace( "#<!--dle_youtube_begin:(.+?)-->(.+?)<!--dle

_youtube_end-->#is", '[youtube=\\1]', $txt );


Заменяем на
$txt = preg_replace( "#<!--dle_youtube_begin:(.+?)-->(.+?)<!--dle

_youtube_end-->#is", '[media=\\1]', $txt );


3) Находим строку (582)
if ($source['host'] != "youtube.com" AND $source['host'] != "rutube.ru") return "[youtube=".$url."]";


Заменяем на
if ($source['host'] != "youtube.com" AND $source['host'] != "rutube.ru") return "[media=".$url."]";


Готово. Видео вставляется нормально.

Сообщение отредактировал mlevox - 6 июня 2011 11:50
Перейти в начало страницы
foxer
6 июня 2011 13:23
Сообщение #17


Активный участник
  • 51

Репутация: 5
Группа: Посетители
Сообщений: 128
Регистрация: 1.08.2010
ICQ:--
mlevox, спасибо, работает :smile:
Перейти в начало страницы
papeion
6 июня 2011 16:21
Сообщение #18


Участник
  • 34

Репутация: 1
Группа: Посетители
Сообщений: 48
Регистрация: 7.01.2008
ICQ:--
Цитата: mlevox
Решил проблему с тегом youtube

Спасибо! Один баг устранён! Остался ещё один.
Перейти в начало страницы
Mek
8 июня 2011 13:11
Сообщение #19


Очень Активный
  • 85

Репутация: 27
Группа: Посетители
Сообщений: 338
Регистрация: 1.11.2008
ICQ:763600
Работает ли HTML в сообщениях на связки DLE 9.3 + DLE-Forum 2.6.1 ?
Перейти в начало страницы
mlevox
8 июня 2011 18:08
Сообщение #20


Новичок
  • 17

Репутация: 3
Группа: Посетители
Сообщений: 16
Регистрация: 18.02.2010
ICQ:--
Цитата: Mek
Работает ли HTML в сообщениях на связки DLE 9.3 + DLE-Forum 2.6.1 ?

Походу нет. У меня не работает.
Перейти в начало страницы
 
« · Прием багов · »
5 страниц 1 2 3 4 5 Далее
Быстрый ответ Ответить
1чел. читают эту тему (гостей: 1)
Пользователей: 0

 
Текстовая версия
Сейчас: 17 сентября 2012 18:50


 
Новости | Продукты | Решения | Обратная связь

Copyright © 2007-2011 DLE Files Group. All Rights Reserved.
 
 
Карта сайта: 1|2|3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|22|23|24|25|26|27|28|29|30|31|32|33|34|35|36|37|38|39|40|41|42|43|44|45|46|47|48|49|50|51|52|53|54|55|56|57|58|59|60|61|62|63|64|65|66|67|68|69|70|71|72|73|74|75|76|77|78|79|80|81|82|83|84|85|86|87|88|89|90|91|92|93|94|95|96|97|98|